<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#">
<head>
    <meta charset="UTF-8">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <link rel="profile" href="http://gmpg.org/xfn/11">

        <script>
        (function (exports, d) {
            var _isReady = false,
                _event,
                _fns = [];

            function onReady(event) {
                d.removeEventListener("DOMContentLoaded", onReady);
                _isReady = true;
                _event = event;
                _fns.forEach(function (_fn) {
                    var fn = _fn[0],
                        context = _fn[1];
                    fn.call(context || exports, window.jQuery);
                });
            }

            function onReadyIe(event) {
                if (d.readyState === "complete") {
                    d.detachEvent("onreadystatechange", onReadyIe);
                    _isReady = true;
                    _event = event;
                    _fns.forEach(function (_fn) {
                        var fn = _fn[0],
                            context = _fn[1];
                        fn.call(context || exports, event);
                    });
                }
            }

            d.addEventListener && d.addEventListener("DOMContentLoaded", onReady) ||
            d.attachEvent && d.attachEvent("onreadystatechange", onReadyIe);

            function domReady(fn, context) {
                if (_isReady) {
                    fn.call(context, _event);
                }

                _fns.push([fn, context]);
            }

            exports.mesmerizeDomReady = domReady;
        })(window, document);
    </script>
	<title>This Week in Linux 94: Mesa 20, PipeWire, Linux Be Scary, MyPaint, GTK, Microsoft Defender &#8211; TuxDigital</title>
<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/tuxdigital.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://tuxdigital.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://tuxdigital.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.6' type='text/css' media='all' />
<link rel='stylesheet' id='swpm.common-css'  href='https://tuxdigital.com/wp-content/plugins/simple-membership/css/swpm.common.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='mesmerize-style-css'  href='https://tuxdigital.com/wp-content/themes/mesmerize-pro/style.min.css?ver=1.6.112' type='text/css' media='all' />
<style id='mesmerize-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='mesmerize-fonts-css'  href='//tuxdigital.com/wp-content/uploads/sgf-css/font-1491d16b276a121a6fdea9af2c516919.css' type='text/css' media='all' />
<link rel='stylesheet' id='mesmerize-style-bundle-css'  href='https://tuxdigital.com/wp-content/themes/mesmerize-pro/pro/assets/css/theme.bundle.min.css?ver=1.6.112' type='text/css' media='all' />
<script type='text/javascript' src='https://tuxdigital.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript'>
    
        (function () {
            function setHeaderTopSpacing() {

                setTimeout(function() {
                  var headerTop = document.querySelector('.header-top');
                  var headers = document.querySelectorAll('.header-wrapper .header,.header-wrapper .header-homepage');

                  for (var i = 0; i < headers.length; i++) {
                      var item = headers[i];
                      item.style.paddingTop = headerTop.getBoundingClientRect().height + "px";
                  }

                    var languageSwitcher = document.querySelector('.mesmerize-language-switcher');

                    if(languageSwitcher){
                        languageSwitcher.style.top = "calc( " +  headerTop.getBoundingClientRect().height + "px + 1rem)" ;
                    }
                    
                }, 100);

             
            }

            window.addEventListener('resize', setHeaderTopSpacing);
            window.mesmerizeSetHeaderTopSpacing = setHeaderTopSpacing
            mesmerizeDomReady(setHeaderTopSpacing);
        })();
    
    
</script>
<script type='text/javascript' src='https://tuxdigital.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://tuxdigital.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://tuxdigital.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://tuxdigital.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Kdenlive: From Beginner to Advanced Video Editing' href='https://tuxdigital.com/2020/02/kdenlive-from-beginner-to-advanced-video-editing/' />
<meta name="generator" content="WordPress 5.3.2" />
<link rel="canonical" href="https://tuxdigital.com/2020/02/thisweekinlinux-94/" />
<link rel='shortlink' href='https://tuxdigital.com/?p=2651' />
<link rel="alternate" type="application/json+oembed" href="https://tuxdigital.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftuxdigital.com%2F2020%2F02%2Fthisweekinlinux-94%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://tuxdigital.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftuxdigital.com%2F2020%2F02%2Fthisweekinlinux-94%2F&#038;format=xml" />
<style>
	#category-posts-6-internal ul {padding: 0;}
#category-posts-6-internal .cat-post-item img {max-width: initial; max-height: initial; margin: initial;}
#category-posts-6-internal .cat-post-author {margin-bottom: 0;}
#category-posts-6-internal .cat-post-thumbnail {margin: 5px 10px 5px 0;}
#category-posts-6-internal .cat-post-item:before {content: ""; clear: both;}
#category-posts-6-internal .cat-post-title {font-size: 15px;}
#category-posts-6-internal .cat-post-current .cat-post-title {font-weight: bold; text-transform: uppercase;}
#category-posts-6-internal .cat-post-date {font-size: 14px; line-height: 18px; font-style: italic; margin-bottom: 5px;}
#category-posts-6-internal .cat-post-comment-num {font-size: 14px; line-height: 18px;}
#category-posts-6-internal .cat-post-item {border-bottom: 1px solid #ccc;	list-style: none; list-style-type: none; margin: 3px 0;	padding: 3px 0;}
#category-posts-6-internal .cat-post-item:last-child {border-bottom: none;}
#category-posts-6-internal .cat-post-item a:after {content: ""; display: table;	clear: both;}
#category-posts-6-internal p {margin:5px 0 0 0}
#category-posts-6-internal li > div {margin:5px 0 0 0; clear:both;}
#category-posts-6-internal .dashicons {vertical-align:middle;}
</style>
	<!-- Matomo -->
<script type="text/javascript">
  var _paq = _paq || [];
  /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//tuxdigital.com/analytics/";
    _paq.push(['setTrackerUrl', u+'piwik.php']);
    _paq.push(['setSiteId', '1']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'piwik.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<noscript><p><img src="//tuxdigital.com/analytics/piwik.php?idsite=1&amp;rec=1" style="border:0;" alt="" /></p></noscript>
<!-- End Matomo Code -->

<link rel='stylesheet' id='1314-css'  href='//tuxdigital.com/wp-content/uploads/custom-css-js/1314.css?v=7240' type='text/css' media='all' />
<script type="text/javascript"><!--
function powerpress_pinw(pinw_url){window.open(pinw_url, 'PowerPressPlayer','toolbar=0,status=0,resizable=1,width=460,height=320');	return false;}
//-->
</script>
        <style data-name="header-gradient-overlay">
            .header .background-overlay {
                background: linear-gradient(135deg , rgba(64,101,146,0.8) 0%, rgba(21,75,145,0.8) 100%);
            }
        </style>
        <script type="text/javascript" data-name="async-styles">
        (function () {
            var links = document.querySelectorAll('link[data-href]');
            for (var i = 0; i < links.length; i++) {
                var item = links[i];
                item.href = item.getAttribute('data-href')
            }
        })();
    </script>
	<link rel="pingback" href="https://tuxdigital.com/xmlrpc.php">
    <style data-prefix="inner_header" data-name="menu-variant-style">/** cached menu style */.mesmerize-inner-page ul.dropdown-menu > li {  color: #DDDDDD; }  .mesmerize-inner-page .fixto-fixed ul.dropdown-menu > li {  color: #DDDDDD; }   .mesmerize-inner-page ul.dropdown-menu.active-line-bottom > li > a, .mesmerize-inner-page ul.dropdown-menu.active-line-bottom > li > a, ul.dropdown-menu.default > li > a, .mesmerize-inner-page ul.dropdown-menu.default > li > a {   border-bottom: 3px solid transparent; }  .mesmerize-inner-page ul.dropdown-menu.active-line-bottom > .current_page_item > a, .mesmerize-inner-page ul.dropdown-menu.active-line-bottom > .current-menu-item > a, ul.dropdown-menu.default > .current_page_item > a, .mesmerize-inner-page ul.dropdown-menu.default > .current-menu-item > a {  border-bottom-color: #406592; }  .mesmerize-inner-page ul.dropdown-menu.active-line-bottom > li:not(.current-menu-item):not(.current_page_item):hover > a, .mesmerize-inner-page ul.dropdown-menu.active-line-bottom > li:not(.current-menu-item):not(.current_page_item).hover > a, ul.dropdown-menu.default > li:not(.current-menu-item):not(.current_page_item):hover > a, .mesmerize-inner-page ul.dropdown-menu.default > li:not(.current-menu-item):not(.current_page_item).hover > a {  color: #588CC8; }  .mesmerize-inner-page .fixto-fixed ul.dropdown-menu.active-line-bottom > .current_page_item > a, .mesmerize-inner-page .fixto-fixed ul.dropdown-menu.active-line-bottom > .current-menu-item > a, .mesmerize-inner-page .fixto-fixed ul.dropdown-menu.default > .current_page_item > a, .mesmerize-inner-page .fixto-fixed ul.dropdown-menu.default > .current-menu-item > a {  border-bottom-color: #DDDDDD; }  .mesmerize-inner-page .fixto-fixed ul.dropdown-menu.active-line-bottom > li:not(.current-menu-item):not(.current_page_item):hover > a, .mesmerize-inner-page .fixto-fixed ul.dropdown-menu.active-line-bottom > li:not(.current-menu-item):not(.current_page_item).hover > a, .mesmerize-inner-page .fixto-fixed ul.dropdown-menu.default > li:not(.current-menu-item):not(.current_page_item):hover > a, .mesmerize-inner-page .fixto-fixed ul.dropdown-menu.default > li:not(.current-menu-item):not(.current_page_item).hover > a {  color: #FFFFFF; }   .mesmerize-inner-page ul.dropdown-menu.active-line-bottom > .current_page_item > a, .mesmerize-inner-page ul.dropdown-menu.active-line-bottom > .current-menu-item > a {  color: #ECECEC; }  .mesmerize-inner-page .fixto-fixed ul.dropdown-menu.active-line-bottom > .current_page_item > a, .mesmerize-inner-page .fixto-fixed ul.dropdown-menu.active-line-bottom > .current-menu-item > a {  color: #ECECEC; } .mesmerize-inner-page ul.dropdown-menu ul {  background-color: rgb(57,57,57); }   .mesmerize-inner-page ul.dropdown-menu ul li {  color: rgb(221,221,221); }  .mesmerize-inner-page ul.dropdown-menu ul li.hover, .mesmerize-inner-page ul.dropdown-menu ul li:hover {  background-color: rgb(64,101,146);  color: rgb(236,236,236); }</style>
    <style data-name="menu-align">.mesmerize-inner-page .main-menu, .mesmerize-inner-page .main_menu_col {justify-content:flex-end;}</style>
            <style data-name="header_content_video_img_shadow">
            .header-description-row img.homepage-header-image,
            .header-description-row .video-popup-button img,
            .header-description-row iframe.header-hero-video {
                -moz-box-shadow: 0 10px 20px rgba(0, 0, 0, 0.19), 0 6px 6px rgba(0, 0, 0, 0.23);
                -webkit-box-shadow: 0 10px 20px rgba(0, 0, 0, 0.19), 0 6px 6px rgba(0, 0, 0, 0.23);
                box-shadow: 0 10px 20px rgba(0, 0, 0, 0.19), 0 6px 6px rgba(0, 0, 0, 0.23);
            }
        </style>
        <style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ececec; }
</style>
	<link rel="icon" href="https://tuxdigital.com/wp-content/uploads/2018/01/cropped-td-penguin-icon-800-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://tuxdigital.com/wp-content/uploads/2018/01/cropped-td-penguin-icon-800-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://tuxdigital.com/wp-content/uploads/2018/01/cropped-td-penguin-icon-800-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://tuxdigital.com/wp-content/uploads/2018/01/cropped-td-penguin-icon-800-270x270.jpg" />

<!-- START - Open Graph and Twitter Card Tags 2.2.7.2 -->
 <!-- Facebook Open Graph -->
  <meta property="og:locale" content="en_US"/>
  <meta property="og:site_name" content="TuxDigital"/>
  <meta property="og:title" content="This Week in Linux 94: Mesa 20, PipeWire, Linux Be Scary, MyPaint, GTK, Microsoft Defender"/>
  <meta property="og:url" content="https://tuxdigital.com/2020/02/thisweekinlinux-94/"/>
  <meta property="og:type" content="article"/>
  <meta property="og:description" content="On this episode of This Week in Linux, we got some new releases from core projects like Mesa &amp; PipeWire and we also got some App News from MyPaint, GTK and a new convergent apps project called Maui. Then we&#039;ll check out some distro news regarding the Untangle Firewall and some Red Hat news about Cor"/>
  <meta property="og:image" content="https://tuxdigital.com/wp-content/uploads/2020/02/twinl94-hd-thumbnail.jpg"/>
  <meta property="og:image:url" content="https://tuxdigital.com/wp-content/uploads/2020/02/twinl94-hd-thumbnail.jpg"/>
  <meta property="og:image:secure_url" content="https://tuxdigital.com/wp-content/uploads/2020/02/twinl94-hd-thumbnail.jpg"/>
  <meta property="article:published_time" content="2020-02-24T23:07:41-06:00"/>
  <meta property="article:modified_time" content="2020-02-25T13:14:18-06:00" />
  <meta property="og:updated_time" content="2020-02-25T13:14:18-06:00" />
  <meta property="article:section" content="Shows"/>
  <meta property="article:section" content="This Week in Linux"/>
  <meta property="article:publisher" content="https://www.facebook.com/tuxdigital"/>
 <!-- Google+ / Schema.org -->
  <meta itemprop="name" content="This Week in Linux 94: Mesa 20, PipeWire, Linux Be Scary, MyPaint, GTK, Microsoft Defender"/>
  <meta itemprop="headline" content="This Week in Linux 94: Mesa 20, PipeWire, Linux Be Scary, MyPaint, GTK, Microsoft Defender"/>
  <meta itemprop="description" content="On this episode of This Week in Linux, we got some new releases from core projects like Mesa &amp; PipeWire and we also got some App News from MyPaint, GTK and a new convergent apps project called Maui. Then we&#039;ll check out some distro news regarding the Untangle Firewall and some Red Hat news about Cor"/>
  <meta itemprop="image" content="https://tuxdigital.com/wp-content/uploads/2020/02/twinl94-hd-thumbnail.jpg"/>
  <meta itemprop="datePublished" content="2020-02-24"/>
  <meta itemprop="dateModified" content="2020-02-25T13:14:18-06:00" />
  <meta itemprop="author" content="Michael Tunnell"/>
  <!--<meta itemprop="publisher" content="TuxDigital"/>--> <!-- To solve: The attribute publisher.itemtype has an invalid value -->
 <!-- Twitter Cards -->
  <meta name="twitter:title" content="This Week in Linux 94: Mesa 20, PipeWire, Linux Be Scary, MyPaint, GTK, Microsoft Defender"/>
  <meta name="twitter:url" content="https://tuxdigital.com/2020/02/thisweekinlinux-94/"/>
  <meta name="twitter:description" content="On this episode of This Week in Linux, we got some new releases from core projects like Mesa &amp; PipeWire and we also got some App News from MyPaint, GTK and a new convergent apps project called Maui. Then we&#039;ll check out some distro news regarding the Untangle Firewall and some Red Hat news about Cor"/>
  <meta name="twitter:image" content="https://tuxdigital.com/wp-content/uploads/2020/02/twinl94-hd-thumbnail.jpg"/>
  <meta name="twitter:card" content="summary_large_image"/>
  <meta name="twitter:site" content="@TuxDigitalcom"/>
 <!-- SEO -->
 <!-- Misc. tags -->
 <!-- is_singular -->
<!-- END - Open Graph and Twitter Card Tags 2.2.7.2 -->
	
    <style id="page-content-custom-styles">
            </style>
            <style data-name="header-shapes">
            .header.color-overlay:after {background:url(https://tuxdigital.com/wp-content/themes/mesmerize-pro/pro/assets/shapes/right-tilted-lines.png) top left repeat}        </style>
            <style data-name="background-content-colors">
        .mesmerize-inner-page .page-content,
        .mesmerize-inner-page .content,
        .mesmerize-front-page.mesmerize-content-padding .page-content {
            background-color: #ececec;
        }
    </style>
                <style data-name="site-colors">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</style>
            </head>

<body class="post-template-default single single-post postid-2651 single-format-standard custom-background wp-custom-logo overlap-first-section mesmerize-inner-page elementor-default">
    <style>
        .screen-reader-text[href="#page-content"]:focus {
            background-color: #f1f1f1;
            border-radius: 3px;
            box-shadow: 0 0 2px 2px rgba(0, 0, 0, 0.6);
            clip: auto !important;
            clip-path: none;
            color: #21759b;
           
        }
    </style>
    <a class="skip-link screen-reader-text" href="#page-content">Skip to content</a>
    
<div  id="page-top" class="header-top small">
        <div class="navigation-bar coloured-nav"  data-sticky='0'  data-sticky-mobile='1'  data-sticky-to='top' >
    <div class="navigation-wrapper dark-logo fixed-dark-logo">
    	<div class="row basis-auto">
	        <div class="logo_col col-xs col-sm-fit">
	            <a href="https://tuxdigital.com/" class="custom-logo-link" data-type="group"  data-dynamic-mod="true" rel="home"><img width="281" height="50" src="https://tuxdigital.com/wp-content/uploads/2018/01/tuxdigital-logo.png" class="custom-logo" alt="TuxDigital" /></a>	        </div>
	        <div class="main_menu_col col-xs">
	            <div id="mainmenu_container" class="row"><ul id="main_menu" class="active-line-bottom main-menu dropdown-menu"><li id="menu-item-696" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-696"><a href="https://tuxdigital.com/shows/">Shows</a>
<ul class="sub-menu">
	<li id="menu-item-695" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-695"><a href="https://tuxdigital.com/thisweekinlinux/">This Week in Linux</a></li>
	<li id="menu-item-694" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-694"><a href="https://tuxdigital.com/linuxexplained/">Linux Explained</a></li>
	<li id="menu-item-693" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-693"><a href="https://tuxdigital.com/howtopronounce/">How To Pronounce</a></li>
</ul>
</li>
<li id="menu-item-191" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-191"><a href="/tag/video/">Videos</a></li>
<li id="menu-item-661" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-661"><a href="/tag/article/">Articles</a></li>
<li id="menu-item-134" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-134"><a href="https://tuxdigital.com/blog/">Blog</a></li>
<li id="menu-item-848" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-848"><a href="https://tuxdigital.com/contribute/">Contribute</a></li>
<li id="menu-item-697" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-697"><a href="https://tuxdigital.com/about/">About</a></li>
<li id="menu-item-698" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-698"><a href="https://tuxdigital.com/contact/">Contact</a></li>
</ul></div>    <a href="#" data-component="offcanvas" data-target="#offcanvas-wrapper" data-direction="right" data-width="300px" data-push="false">
        <div class="bubble"></div>
        <i class="fa fa-bars"></i>
    </a>
    <div id="offcanvas-wrapper" class="hide force-hide  offcanvas-right">
        <div class="offcanvas-top">
            <div class="logo-holder">
                <a href="https://tuxdigital.com/" class="custom-logo-link" data-type="group"  data-dynamic-mod="true" rel="home"><img width="281" height="50" src="https://tuxdigital.com/wp-content/uploads/2018/01/tuxdigital-logo.png" class="custom-logo" alt="TuxDigital" /></a>            </div>
        </div>
        <div id="offcanvas-menu" class="menu-main-menu-container"><ul id="offcanvas_menu" class="offcanvas_menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-696"><a href="https://tuxdigital.com/shows/">Shows</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-695"><a href="https://tuxdigital.com/thisweekinlinux/">This Week in Linux</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-694"><a href="https://tuxdigital.com/linuxexplained/">Linux Explained</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-693"><a href="https://tuxdigital.com/howtopronounce/">How To Pronounce</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-191"><a href="/tag/video/">Videos</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-661"><a href="/tag/article/">Articles</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-134"><a href="https://tuxdigital.com/blog/">Blog</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-848"><a href="https://tuxdigital.com/contribute/">Contribute</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-697"><a href="https://tuxdigital.com/about/">About</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-698"><a href="https://tuxdigital.com/contact/">Contact</a></li>
</ul></div>
            <div data-type="group"  data-dynamic-mod="true" class="social-icons">
                      <a target="_blank"  class="social-icon" href="http://twitter.com/tuxdigitalcom">
                  <i class="fa fa-twitter-square"></i>
              </a>
                            <a target="_blank"  class="social-icon" href="http://facebook.com/tuxdigital">
                  <i class="fa fa-facebook-square"></i>
              </a>
                            <a target="_blank"  class="social-icon" href="https://www.instagram.com/tuxdigitalcom/">
                  <i class="fa fa-instagram"></i>
              </a>
                            <a target="_blank"  class="social-icon" href="https://tuxdigital.com/telegram">
                  <i class="fa fa-telegram"></i>
              </a>
              
    </div>

        </div>
    	        </div>
	    </div>
    </div>
</div>
</div>

<div id="page" class="site">
    <div id='page-content' class="content post-page">
        <div class="gridContainer">
            <div class="row">
                <div class="col-xs-12 col-sm-8 col-md-9">
                    <div class="post-item">
						<div id="post-2651"class="post-2651 post type-post status-publish format-standard has-post-thumbnail hentry category-shows category-this-week-in-linux tag-linux tag-open-source tag-podcast tag-this-week-in-linux tag-zhfimg">

    <div class="post-content-single">

        <h2 class="h1">This Week in Linux 94: Mesa 20, PipeWire, Linux Be Scary, MyPaint, GTK, Microsoft Defender</h2>
        
        

<div class="post-meta muted">

  <i class="font-icon-post fa fa-user"></i>
  <a href="https://tuxdigital.com/author/michaeltuxdigital-com/" title="Posts by Michael Tunnell" rel="author">Michael Tunnell</a>
  &nbsp;&nbsp;<i class="font-icon-post fa fa-folder-o"></i>
  <a href="https://tuxdigital.com/category/shows/" rel="category tag">Shows</a> <a href="https://tuxdigital.com/category/shows/this-week-in-linux/" rel="category tag">This Week in Linux</a>
  &nbsp;&nbsp;<i class="font-icon-post fa fa-calendar"></i>
  <span class="post-date">2020-02-24</span>


  &nbsp;|&nbsp;<i class="font-icon-post fa fa-comment-o"></i>
  <span>2</span>
</div>

        <div class="post-content-inner">
            
            <img width="1120" height="630" src="https://tuxdigital.com/wp-content/uploads/2020/02/twinl94-hd-thumbnail.jpg" class="space-bottom-small space-bottom-xs wp-post-image" alt="" srcset="https://tuxdigital.com/wp-content/uploads/2020/02/twinl94-hd-thumbnail.jpg 1920w, https://tuxdigital.com/wp-content/uploads/2020/02/twinl94-hd-thumbnail-300x169.jpg 300w, https://tuxdigital.com/wp-content/uploads/2020/02/twinl94-hd-thumbnail-1024x576.jpg 1024w, https://tuxdigital.com/wp-content/uploads/2020/02/twinl94-hd-thumbnail-768x432.jpg 768w, https://tuxdigital.com/wp-content/uploads/2020/02/twinl94-hd-thumbnail-1536x864.jpg 1536w" sizes="(max-width: 1120px) 100vw, 1120px" /><div class="video-container"><iframe src="https://www.youtube-nocookie.com/embed/8xeZ62RauTs?feature=oembed&start&end&wmode=opaque&loop=0&controls=1&mute=0&rel=0&modestbranding=1" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div>
<p>On this episode of This Week in Linux, we got some new releases from core projects like Mesa &#038; PipeWire and we also got some App News from MyPaint, GTK and a new convergent apps project called Maui. Then we&#8217;ll check out some distro news regarding the Untangle Firewall and some Red Hat news about CoreOS Container Linux. Later in the show, we&#8217;ll cover some really interesting news from Nvidia about Ray Tracing to Vulkan. Someone in the UK Police thought it was a good idea to warn parents their kids may become hackers and Microsoft announced their Microsoft Defender is coming to Linux. Then we&#8217;ll round out the show with some great deals for Games, Books and Comics from Humble Bundle. All that and much more on Your Weekly Source for Linux GNews!</p>
<p><span id="more-2651"></span></p>
<p>Sponsored by: <a href="https://do.co/dln" target="_blank" rel="noopener noreferrer">do.co/dln</a><br />
<a href="https://do.co/dln" target="_blank" rel="noopener noreferrer"><img src="https://tuxdigital.com/wp-content/uploads/2019/01/digital-ocean-banner.png" alt="" width="468" height="60" class="alignnone size-full wp-image-1499" srcset="https://tuxdigital.com/wp-content/uploads/2019/01/digital-ocean-banner.png 468w, https://tuxdigital.com/wp-content/uploads/2019/01/digital-ocean-banner-300x38.png 300w" sizes="(max-width: 468px) 100vw, 468px" /></a></p>
<h3>Downloads &#038; Media</h3>
<p><a class="btn-global" href=""><i class="fa fa-volume-up"></i>&nbsp;MP3</a><a class="btn-global" href="https://www.youtube.com/watch?v=8xeZ62RauTs"><i class="fa fa-youtube-play"></i>&nbsp;YouTube</a><a class="btn-global" href="https://lbry.tv/@tuxdigital:a/this-week-in-linux-94-mesa-20-pipewire:e"><i class="fa fa-play"></i>&nbsp;LBRY</a></p>
<div class="post-links subscribe"><h3>Subscribe to This Week in Linux:</h3><a class="btn-global feed" href="https://tuxdigital.com/feed/thisweekinlinux-mp3" target="_blank"><i class="fa fa-volume-up"></i> MP3 RSS Feed</a><a class="btn-global feed" href="http://subscribebyemail.com/tuxdigital.com/feed/thisweekinlinux-mp3" target="_blank"><i class="fa fa-envelope"></i> Email</a><a class="btn-global feed" href="http://subscribeonandroid.com/tuxdigital.com/feed/thisweekinlinux-mp3" target="_blank"><i class="fa fa-android"></i> Android</a><a class="btn-global feed" href="https://tuxdigital.com/ytsubscribe" target="_blank"><i class="fa fa-youtube"></i> YouTube</a></div>
<h4>Become a Patron:</h4>
<ul>
<li><a href="https://tuxdigital.com/patreon" target="_blank" rel="noopener noreferrer">https://tuxdigital.com/patreon</a></li>
<li><a href="https://tuxdigital.com/sponsus" target="_blank" rel="noopener noreferrer">https://tuxdigital.com/sponsus</a></li>
<li><a href="https://tuxdigital.com/contribute" target="_blank" rel="noopener noreferrer">https://tuxdigital.com/contribute</a></li>
</ul>
<h4>Other Links:</h4>
<ul>
<li><a href="https://michaeltunnell.com" target="_blank" rel="noopener noreferrer">https://michaeltunnell.com</a></li>
<li><a href="https://tuxdigital.com/linuxiseverywhere" target="_blank" rel="noopener noreferrer">https://tuxdigital.com/linuxiseverywhere</a></li>
<li><a href="https://tuxdigital.com/linuxiseverywhereeu" target="_blank" rel="noopener noreferrer">https://tuxdigital.com/linuxiseverywhereeu</a></li>
</ul>
<h4>&#8220;Affiliate Links to Help This Show&#8221; News:</h4>
<ul>
<li><a href="https://tuxdigital.com/go/humble-vr-bundle" target="_blank" rel="noopener noreferrer">https://tuxdigital.com/go/humble-vr-bundle</a></li>
<li><a href="https://tuxdigital.com/go/humble-digital-tabletop-2" target="_blank" rel="noopener noreferrer">https://tuxdigital.com/go/humble-digital-tabletop-2</a></li>
<li><a href="https://tuxdigital.com/go/humble-best-of-polygon-game-dev" target="_blank" rel="noopener noreferrer">https://tuxdigital.com/go/humble-best-of-polygon-game-dev</a></li>
<li><a href="https://tuxdigital.com/go/humble-cybersecurity-2020-wiley-books" target="_blank" rel="noopener noreferrer">https://tuxdigital.com/go/humble-cybersecurity-2020-wiley-books</a></li>
<li><a href="https://tuxdigital.com/go/humble-user-experience-ux-design-books" target="_blank" rel="noopener noreferrer">https://tuxdigital.com/go/humble-user-experience-ux-design-books</a></li>
<li><a href="https://tuxdigital.com/go/humble-bloodshot-2020-valiant-books" target="_blank" rel="noopener noreferrer">https://tuxdigital.com/go/humble-bloodshot-2020-valiant-books</a></li>
</ul>
<h3>Segment Index</h3>
<ul>
<li><a href="https://www.youtube.com/watch?v=8xeZ62RauTs&amp;t=00m52s" target="_blank" rel="noopener noreferrer">00:52</a> = Ryan (DasGeek) Intro · [<a href="https://destinationlinux.org" target="_blank" rel="noopener noreferrer">destinationlinux.org</a>]</li>
<li><a href="https://www.youtube.com/watch?v=8xeZ62RauTs&amp;t=01m06s" target="_blank" rel="noopener noreferrer">01:06</a> = Mesa 20.0 Released (3D Graphics Library) · [Links: <a href="https://lists.freedesktop.org/archives/mesa-dev/2020-February/224132.html" target="_blank" rel="noopener noreferrer">freedesktop.org</a>, <a href="https://www.phoronix.com/scan.php?page=news_item&#038;px=Mesa-20.0-Released" target="_blank" rel="noopener noreferrer">phoronix.com</a>, <a href="https://www.gamingonlinux.com/articles/mesa-drivers-2000-released-nvidia-also-have-a-small-vulkan-driver-update-out.16040" target="_blank" rel="noopener noreferrer">gamingonlinux.com</a>]</li>
<li><a href="https://www.youtube.com/watch?v=8xeZ62RauTs&amp;t=02m28s" target="_blank" rel="noopener noreferrer">02:28</a> = PipeWire 0.3 Released · [<a href="https://pipewire.org" target="_blank" rel="noopener noreferrer">pipewire.org</a>]</li>
<li><a href="https://www.youtube.com/watch?v=8xeZ62RauTs&amp;t=04m26s" target="_blank" rel="noopener noreferrer">04:26</a> = Sponsored by Digital Ocean · [<a href="https://do.co/dln" target="_blank" rel="noopener noreferrer">do.co/dln</a>]</li>
<li><a href="https://www.youtube.com/watch?v=8xeZ62RauTs&amp;t=05m43s" target="_blank" rel="noopener noreferrer">05:43</a> = MyPaint v2.0.0 Released · [<a href="http://mypaint.org/blog/2020/02/16/MyPaint-2.0.0-release/" target="_blank" rel="noopener noreferrer">mypaint.org</a>]</li>
<li><a href="https://www.youtube.com/watch?v=8xeZ62RauTs&amp;t=07m48s" target="_blank" rel="noopener noreferrer">07:48</a> = GTK Website Gets Redesign · [Links: <a href="https://web.archive.org/web/20200214231638/https://gtk.org/" target="_blank" rel="noopener noreferrer">Before</a> and <a href="https://gtk.org/" target="_blank" rel="noopener noreferrer">After</a>]</li>
<li><a href="https://www.youtube.com/watch?v=8xeZ62RauTs&amp;t=11m11s" target="_blank" rel="noopener noreferrer">11:11</a> = Maui Project for Convergent Apps · [<a href="https://mauikit.org" target="_blank" rel="noopener noreferrer">mauikit.org</a>]</li>
<li><a href="https://www.youtube.com/watch?v=8xeZ62RauTs&amp;t=14m04s" target="_blank" rel="noopener noreferrer">14:04</a> = Become a Patron of TuxDigital · [<a href="https://tuxdigital.com/contribute" target="_blank" rel="noopener noreferrer">tuxdigital.com/contribute</a>]</li>
<li><a href="https://www.youtube.com/watch?v=8xeZ62RauTs&amp;t=14m52s" target="_blank" rel="noopener noreferrer">14:52</a> = TuxDigital on LBRY · [<a href="https://tuxdigital.com/lbry" target="_blank" rel="noopener noreferrer">tuxdigital.com/lbry</a>]</li>
<li><a href="https://www.youtube.com/watch?v=8xeZ62RauTs&amp;t=15m47s" target="_blank" rel="noopener noreferrer">15:47</a> = Hardware Addicts podcast from DLN · [<a href="https://hardwareaddicts.org" target="_blank" rel="noopener noreferrer">hardwareaddicts.org</a>]</li>
<li><a href="https://www.youtube.com/watch?v=8xeZ62RauTs&amp;t=17m02s" target="_blank" rel="noopener noreferrer">17:02</a> = New DLN YouTube channel (one stop shop) · [<a href="https://destinationlinux.network/youtube" target="_blank" rel="noopener noreferrer">destinationlinux.network/youtube</a>]</li>
<li><a href="https://www.youtube.com/watch?v=8xeZ62RauTs&amp;t=17m55s" target="_blank" rel="noopener noreferrer">17:55</a> = Join the DLN Forum to become part of the DLN Community · [<a href="https://discourse.destinationlinux.network" target="_blank" rel="noopener noreferrer">discourse.destinationlinux.network</a>]</li>
<li><a href="https://www.youtube.com/watch?v=8xeZ62RauTs&amp;t=18m50s" target="_blank" rel="noopener noreferrer">18:50</a> = Untangle NG Firewall 15.0 Released · [<a href="https://www.untangle.com/press-releases/untangle-releases-ng-firewall-15-0-to-keep-smb-assets-safe-from-todays-evolving-threats/" target="_blank" rel="noopener noreferrer">untangle.com</a>]</li>
<li><a href="https://www.youtube.com/watch?v=8xeZ62RauTs&amp;t=20m44s" target="_blank" rel="noopener noreferrer">20:44</a> = Container Linux Reaches End of Life · [<a href="https://coreos.com/os/eol/" target="_blank" rel="noopener noreferrer">coreos.com</a>]</li>
<li><a href="https://www.youtube.com/watch?v=8xeZ62RauTs&amp;t=24m47s" target="_blank" rel="noopener noreferrer">24:47</a> = NVIDIA Porting of Ray-Tracing To Vulkan · [<a href="https://devblogs.nvidia.com/bringing-hlsl-ray-tracing-to-vulkan/" target="_blank" rel="noopener noreferrer">devblogs.nvidia.com</a>]</li>
<li><a href="https://www.youtube.com/watch?v=8xeZ62RauTs&amp;t=26m57s" target="_blank" rel="noopener noreferrer">26:57</a> = UK Police: Your Kids May Become Hackers · [Links: <a href="https://twitter.com/G_IW/status/1227700420178567170" target="_blank" rel="noopener noreferrer">@G_IW</a>, <a href="https://twitter.com/kalilinux/status/1227703199584395267" target="_blank" rel="noopener noreferrer">@kalilinux</a>, <a href="https://twitter.com/NCA_UK/status/1228092570422718464" target="_blank" rel="noopener noreferrer">@NCA_UK</a>, <a href="https://www.zdnet.com/article/uk-police-distance-themselves-from-poster-warning-parents-to-report-kids-for-using-kali-linux/" target="_blank" rel="noopener noreferrer">zdnet.com</a>]</li>
<li><a href="https://www.youtube.com/watch?v=8xeZ62RauTs&amp;t=32m15s" target="_blank" rel="noopener noreferrer">32:15</a> = Microsoft Defender ATP Preview for Linux · [<a href="https://www.microsoft.com/security/blog/2020/02/20/microsoft-threat-protection-intelligence-automation/" target="_blank" rel="noopener noreferrer">microsoft.com</a>]</li>
<li><a href="https://www.youtube.com/watch?v=8xeZ62RauTs&amp;t=36m31s" target="_blank" rel="noopener noreferrer">36:31</a> = Humble Bundles Galore · (scroll up for links)</li>
<li><a href="https://www.youtube.com/watch?v=8xeZ62RauTs&amp;t=44m04s" target="_blank" rel="noopener noreferrer">44:04</a> = Outro</li>
</ul>

        </div>
        
        <p class="tags-list"><i data-cp-fa="true" class="font-icon-25 fa fa-tags"></i>&nbsp;<a href="https://tuxdigital.com/tag/linux/" rel="tag">Linux</a> <a href="https://tuxdigital.com/tag/open-source/" rel="tag">Open Source</a> <a href="https://tuxdigital.com/tag/podcast/" rel="tag">podcast</a> <a href="https://tuxdigital.com/tag/this-week-in-linux/" rel="tag">This Week in Linux</a> <a href="https://tuxdigital.com/tag/zhfimg/" rel="tag">zhfimg</a></p>
    </div>
    
    
    
	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://tuxdigital.com/2020/02/kdenlive-from-beginner-to-advanced-video-editing/" rel="prev"><i class="font-icon-post fa fa-angle-double-left"></i><span class="meta-nav" aria-hidden="true">Previous:</span> <span class="screen-reader-text">Previous post:</span> <span class="post-title">Kdenlive: From Beginner to Advanced Video Editing</span></a></div></div>
	</nav>		<div id="comments" class="comments-area discourse-comments-area">
			<div class="comments-title-wrap">
				<h2 class="comments-title discourse-comments-title">Notable Replies</h2>
			</div>
			<ol class="comment-list">		<li class="comment even depth-1">
			<article class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt="" src="https://discourse.destinationlinux.network/user_avatar/discourse.destinationlinux.network/ak2020/64/158_2.png" class="avatar avatar-64 photo avatar-default" height="64" width="64">
						<b class="fn"><a href="https://discourse.destinationlinux.network/t/this-week-in-linux-94-mesa-20-pipewire-linux-be-scary-mypaint-gtk-microsoft-defender/1499" rel="external" class="url">ak2020</a></b>
						<span class="says screen-reader-text">says:</span><!-- screen reader text -->
					</div>
					<div class="comment-metadata">
						<time datetime="2020-02-25">2020-02-25</time>
					</div>
				</footer>
				<div class="comment-content"><p>Thanks, Michael -  a lot here in this episode and I really enjoyed it <img src="https://discourse.destinationlinux.network/images/emoji/emoji_one/slight_smile.png?v=9" title=":slight_smile:" class="emoji" alt=":slight_smile:"> I think the little intro from a creator of associated DLN show is a great idea - I love <a class="mention" href="https://discourse.destinationlinux.network/u/dasgeek">@dasgeek</a> 's “Fill your brains” line!</p>
<p>Sounds like some sterling under-the-hood work is ongoing with <strong>Mesa</strong> and <strong>Pipeline</strong>. I have to say I’ve never quite got my head around Alsa / PulseAudio and never really had to setup Jack, which apparently is quite complex, so if it’s all going to be simplified in the future that’s good news. Also as far as GUI toolkits go, I’ve never really taken a liking to any of them, not <strong>Gtk</strong>, not Qt, nor the Microsoft helpings… I know Oracle aren’t the most open-source friendly organsation, but I settled on <strong>Java</strong> as a solution for portable GUIs before Oracle took over from Sun. To that end, I have to say <strong>Maui</strong> sounds a lot more interesting because it can also target mobile. I’d really like to see an effective platform for this as again, I’ve yet to find a portable GUI toolkit that I like for mobile development too. The <strong>Linux Be Scary</strong> sections were funny! No thanks to Microsoft Defender, especially after news of what Avast was caught doing recently <img src="https://discourse.destinationlinux.network/images/emoji/emoji_one/frowning.png?v=9" title=":frowning:" class="emoji" alt=":frowning:"></p></div>
			</article>
		</li>
				<li class="comment odd depth-1">
			<article class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt="" src="https://discourse.destinationlinux.network/user_avatar/discourse.destinationlinux.network/friardest/64/1089_2.png" class="avatar avatar-64 photo avatar-default" height="64" width="64">
						<b class="fn"><a href="https://discourse.destinationlinux.network/t/this-week-in-linux-94-mesa-20-pipewire-linux-be-scary-mypaint-gtk-microsoft-defender/1499" rel="external" class="url">FriarDest</a></b>
						<span class="says screen-reader-text">says:</span><!-- screen reader text -->
					</div>
					<div class="comment-metadata">
						<time datetime="2020-02-25">2020-02-25</time>
					</div>
				</footer>
				<div class="comment-content"><p>Hey Michael, I just wanted to comment regarding Microsoft Defender ATP, specifically your skepticism of businesses actually asking for it - I assure you they do exist. As was commented on one of the other DLN shows recently, this may actually prove to be a positive move for some of us who want to run Linux on our workstations but can’t due to corporate compliance policies regarding “approved” antivirus software. It likely won’t affect regular everyday users - but that’s very much not who Microsoft is targeting here. With an officially blessed AV solution this clears one more hurdle for Linux workstations in the enterprise.</p></div>
			</article>
		</li>
		</ol>
			<div class="respond comment-respond">
				<h3 id="reply-title" class="comment-reply-title">
					Continue the discussion at 								<a class="wpdc-discourse-topic-link" target="_blank" href="https://discourse.destinationlinux.network/t/this-week-in-linux-94-mesa-20-pipewire-linux-be-scary-mypaint-gtk-microsoft-defender/1499">discourse.destinationlinux.network</a>
							</h3>
				<p class="more-replies"></p>
				<div class="comment-reply-title">
					<h4 class="discourse-participants">Participants</h4>
					<p>		<img alt="" src="https://discourse.destinationlinux.network/user_avatar/discourse.destinationlinux.network/friardest/64/1089_2.png" class="avatar avatar-25 photo avatar-default" height="25" width="25">
				<img alt="" src="https://discourse.destinationlinux.network/user_avatar/discourse.destinationlinux.network/ak2020/64/158_2.png" class="avatar avatar-25 photo avatar-default" height="25" width="25">
				<img alt="" src="https://discourse.destinationlinux.network/user_avatar/discourse.destinationlinux.network/michaeltunnell/64/5_2.png" class="avatar avatar-25 photo avatar-default" height="25" width="25">
		</p>
				</div>
			</div>
		</div>
		
</div>
                    </div>
                </div>
				
<div class="sidebar col-sm-4 col-md-3">
    <div class="sidebar-row">
        <div id="search-2" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://tuxdigital.com/">
    <label>
        <span class="screen-reader-text">Search for:</span>
        <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s"/>
    </label>
</form>
</div><div id="category-posts-2" class="widget cat-post-widget"><h5 class="widgettitle"><a href="">Recent Posts</a></h5><ul id="category-posts-2-internal" class="category-posts-internal">
<li class='cat-post-item'><div><a class="cat-post-title" href="https://tuxdigital.com/2020/02/kdenlive-from-beginner-to-advanced-video-editing/" rel="bookmark">Kdenlive: From Beginner to Advanced Video Editing</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="https://tuxdigital.com/2020/02/thisweekinlinux-93/" rel="bookmark">This Week in Linux 93: MATE 1.24, KDE Plasma 5.18, Blender, OpenShot, Evernote, MX Linux</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="https://tuxdigital.com/2020/02/episode-92-this-week-in-linux/" rel="bookmark">Episode 92 | This Week in Linux</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="https://tuxdigital.com/2020/01/epic-games-kills-rocket-league-on-linux-reaction/" rel="bookmark">Epic Games Kills Rocket League on Linux! (Reaction)</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="https://tuxdigital.com/2020/01/unboxing-of-the-kubuntu-focus-laptop/" rel="bookmark">Unboxing of the Kubuntu Focus Laptop</a></div></li></ul>
</div><div id="archives-2" class="widget widget_archive"><h5 class="widgettitle">Archives</h5>		<label class="screen-reader-text" for="archives-dropdown-2">Archives</label>
		<select id="archives-dropdown-2" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://tuxdigital.com/2020/02/'> February 2020 &nbsp;(4)</option>
	<option value='https://tuxdigital.com/2020/01/'> January 2020 &nbsp;(2)</option>
	<option value='https://tuxdigital.com/2019/12/'> December 2019 &nbsp;(3)</option>
	<option value='https://tuxdigital.com/2019/11/'> November 2019 &nbsp;(3)</option>
	<option value='https://tuxdigital.com/2019/10/'> October 2019 &nbsp;(3)</option>
	<option value='https://tuxdigital.com/2019/09/'> September 2019 &nbsp;(2)</option>
	<option value='https://tuxdigital.com/2019/08/'> August 2019 &nbsp;(5)</option>
	<option value='https://tuxdigital.com/2019/07/'> July 2019 &nbsp;(5)</option>
	<option value='https://tuxdigital.com/2019/06/'> June 2019 &nbsp;(4)</option>
	<option value='https://tuxdigital.com/2019/05/'> May 2019 &nbsp;(4)</option>
	<option value='https://tuxdigital.com/2019/04/'> April 2019 &nbsp;(4)</option>
	<option value='https://tuxdigital.com/2019/03/'> March 2019 &nbsp;(5)</option>
	<option value='https://tuxdigital.com/2019/02/'> February 2019 &nbsp;(4)</option>
	<option value='https://tuxdigital.com/2019/01/'> January 2019 &nbsp;(5)</option>
	<option value='https://tuxdigital.com/2018/12/'> December 2018 &nbsp;(5)</option>
	<option value='https://tuxdigital.com/2018/11/'> November 2018 &nbsp;(2)</option>
	<option value='https://tuxdigital.com/2018/10/'> October 2018 &nbsp;(5)</option>
	<option value='https://tuxdigital.com/2018/09/'> September 2018 &nbsp;(4)</option>
	<option value='https://tuxdigital.com/2018/08/'> August 2018 &nbsp;(1)</option>
	<option value='https://tuxdigital.com/2018/07/'> July 2018 &nbsp;(3)</option>
	<option value='https://tuxdigital.com/2018/06/'> June 2018 &nbsp;(2)</option>
	<option value='https://tuxdigital.com/2018/05/'> May 2018 &nbsp;(1)</option>
	<option value='https://tuxdigital.com/2018/04/'> April 2018 &nbsp;(3)</option>
	<option value='https://tuxdigital.com/2018/03/'> March 2018 &nbsp;(3)</option>
	<option value='https://tuxdigital.com/2018/02/'> February 2018 &nbsp;(3)</option>
	<option value='https://tuxdigital.com/2018/01/'> January 2018 &nbsp;(1)</option>
	<option value='https://tuxdigital.com/2017/12/'> December 2017 &nbsp;(3)</option>
	<option value='https://tuxdigital.com/2017/11/'> November 2017 &nbsp;(4)</option>
	<option value='https://tuxdigital.com/2017/10/'> October 2017 &nbsp;(4)</option>
	<option value='https://tuxdigital.com/2017/08/'> August 2017 &nbsp;(3)</option>
	<option value='https://tuxdigital.com/2017/06/'> June 2017 &nbsp;(2)</option>
	<option value='https://tuxdigital.com/2017/05/'> May 2017 &nbsp;(1)</option>
	<option value='https://tuxdigital.com/2017/04/'> April 2017 &nbsp;(3)</option>
	<option value='https://tuxdigital.com/2016/07/'> July 2016 &nbsp;(1)</option>
	<option value='https://tuxdigital.com/2016/06/'> June 2016 &nbsp;(1)</option>
	<option value='https://tuxdigital.com/2016/05/'> May 2016 &nbsp;(1)</option>
	<option value='https://tuxdigital.com/2016/04/'> April 2016 &nbsp;(1)</option>

		</select>

<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-2" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>

		</div><div id="categories-2" class="widget widget_categories"><h5 class="widgettitle">Blog Categories</h5>		<ul>
				<li class="cat-item cat-item-42"><a href="https://tuxdigital.com/category/shows/how-to-pronounce/">How To Pronounce</a>
</li>
	<li class="cat-item cat-item-5"><a href="https://tuxdigital.com/category/shows/linux-explained/">Linux Explained</a>
</li>
	<li class="cat-item cat-item-44"><a href="https://tuxdigital.com/category/tuxdigital/news/">News</a>
</li>
	<li class="cat-item cat-item-72"><a href="https://tuxdigital.com/category/product-reviews/">Product Reviews</a>
</li>
	<li class="cat-item cat-item-4"><a href="https://tuxdigital.com/category/shows/">Shows</a>
</li>
	<li class="cat-item cat-item-2"><a href="https://tuxdigital.com/category/shows/this-week-in-linux/">This Week in Linux</a>
</li>
	<li class="cat-item cat-item-43"><a href="https://tuxdigital.com/category/tuxdigital/">TuxDigital</a>
</li>
	<li class="cat-item cat-item-1"><a href="https://tuxdigital.com/category/uncategorized/">Uncategorized</a>
</li>
		</ul>
			</div>    </div>
</div>
            </div>
        </div>

    </div>
<div  class='footer footer-7'>
    <div  class='footer-content small' style=''>
        <div class="gridContainer">
            <div class="row">
                <div class="col-sm-5 last-xs first-sm">
                    <h4>
                        <span data-type="group"  data-dynamic-mod="true">TuxDigital</span>                    </h4>
                    <p class="footer-description"   >TuxDigital is a Educational media channel that advocates for Linux-based operating systems through teaching, training, and distribution of information. TuxDigital aims to help people <em>Use, Learn, and Enjoy Linux</em>.<br /><br /><a href="/contribute">Contribute</a></p>
                    <p  class="copyright" data-type="group" >© 2020 TuxDigital</p>                </div>
                <div class="col-sm-6 three-widgets-area">
                    <div class="row">
                        <div class="col-sm-4">
                             <div id="nav_menu-3" class="widget widget_nav_menu"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-575" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-575"><a href="https://tuxdigital.com/tag/video">Videos</a></li>
<li id="menu-item-699" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-699"><a href="https://tuxdigital.com/tag/article">Articles</a></li>
<li id="menu-item-574" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-574"><a href="https://tuxdigital.com/blog/">Blog</a></li>
<li id="menu-item-572" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-572"><a href="https://tuxdigital.com/about/">About</a></li>
<li id="menu-item-573" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-573"><a href="https://tuxdigital.com/contact/">Contact</a></li>
</ul></div></div>                        </div>
                        <div class="col-sm-4">
                            <div id="category-posts-6" class="widget cat-post-widget"><ul id="category-posts-6-internal" class="category-posts-internal">
<li class='cat-post-item'><a class="cat-post-everything-is-link" href="https://tuxdigital.com/2020/02/kdenlive-from-beginner-to-advanced-video-editing/" title=""><div><span class="cat-post-title">Kdenlive: From Beginner to Advanced Video Editing</span></div></a></li><li class='cat-post-item'><a class="cat-post-everything-is-link" href="https://tuxdigital.com/2020/02/thisweekinlinux-93/" title=""><div><span class="cat-post-title">This Week in Linux 93: MATE 1.24, KDE Plasma 5.18, Blender, OpenShot, Evernote, MX Linux</span></div></a></li><li class='cat-post-item'><a class="cat-post-everything-is-link" href="https://tuxdigital.com/2020/02/episode-92-this-week-in-linux/" title=""><div><span class="cat-post-title">Episode 92 | This Week in Linux</span></div></a></li><li class='cat-post-item'><a class="cat-post-everything-is-link" href="https://tuxdigital.com/2020/01/epic-games-kills-rocket-league-on-linux-reaction/" title=""><div><span class="cat-post-title">Epic Games Kills Rocket League on Linux! (Reaction)</span></div></a></li><li class='cat-post-item'><a class="cat-post-everything-is-link" href="https://tuxdigital.com/2020/01/unboxing-of-the-kubuntu-focus-laptop/" title=""><div><span class="cat-post-title">Unboxing of the Kubuntu Focus Laptop</span></div></a></li></ul>
</div><div id="text-3" class="widget widget_text"><h4 class="widgettitle">LiveStream Banner</h4>			<div class="textwidget">
</div>
		</div>                        </div>
                        <div class="col-sm-4">
                                                    </div>
                    </div>
                </div>
                    <div data-type="group"  data-dynamic-mod="true" class="col-sm-1 footer-social-icons flexbox center-xs start-sm bottom-sm">
                      <a target="_blank"  class="social-icon" href="http://twitter.com/tuxdigitalcom">
                  <i class="fa fa-twitter-square"></i>
              </a>
                            <a target="_blank"  class="social-icon" href="http://facebook.com/tuxdigital">
                  <i class="fa fa-facebook-square"></i>
              </a>
                            <a target="_blank"  class="social-icon" href="https://www.instagram.com/tuxdigitalcom/">
                  <i class="fa fa-instagram"></i>
              </a>
                            <a target="_blank"  class="social-icon" href="https://mastodon.social/@TuxDigital">
                  <i class="fa fa-maxcdn"></i>
              </a>
                            <a target="_blank"  class="social-icon" href="https://tuxdigital.com/telegram">
                  <i class="fa fa-telegram"></i>
              </a>
              
    </div>

                </div>
        </div>
    </div>
</div>
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/tuxdigital.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://tuxdigital.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.6'></script>
<script type='text/javascript' src='https://tuxdigital.com/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript'  defer="defer" src='https://tuxdigital.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript'  defer="defer" src='https://tuxdigital.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mesmerize_theme_pro_settings = {"reveal-effect":{"enabled":false}};
/* ]]> */
</script>
<script type='text/javascript'  defer="defer" src='https://tuxdigital.com/wp-content/themes/mesmerize-pro/pro/assets/js/theme.bundle.min.js?ver=1.6.112'></script>
<script type='text/javascript'  defer="defer" src='https://tuxdigital.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
    <script>
        /(trident|msie)/i.test(navigator.userAgent) && document.getElementById && window.addEventListener && window.addEventListener("hashchange", function () {
            var t, e = location.hash.substring(1);
            /^[A-z0-9_-]+$/.test(e) && (t = document.getElementById(e)) && (/^(?:a|select|input|button|textarea)$/i.test(t.tagName) || (t.tabIndex = -1), t.focus())
        }, !1);
    </script>
		<script type="text/javascript">
        jQuery(document).ready(function ($) {
            //$( document ).ajaxStart(function() {
            //});

			
            for (var i = 0; i < document.forms.length; ++i) {
                var form = document.forms[i];
				if ($(form).attr("method") != "get") { $(form).append('<input type="hidden" name="ZHoGFhQlNxwMkPqI" value="1S3jYpvWBGbXJETi" />'); }
if ($(form).attr("method") != "get") { $(form).append('<input type="hidden" name="dBAMxnO-gmNza" value="V4m[xs8bIuS.r" />'); }
if ($(form).attr("method") != "get") { $(form).append('<input type="hidden" name="RPiZHMdbNYyt" value="wimoqvRFLUfO" />'); }
if ($(form).attr("method") != "get") { $(form).append('<input type="hidden" name="MLbOnVgTt" value="MBri[LQ4N" />'); }
            }

			
            $(document).on('submit', 'form', function () {
				if ($(this).attr("method") != "get") { $(this).append('<input type="hidden" name="ZHoGFhQlNxwMkPqI" value="1S3jYpvWBGbXJETi" />'); }
if ($(this).attr("method") != "get") { $(this).append('<input type="hidden" name="dBAMxnO-gmNza" value="V4m[xs8bIuS.r" />'); }
if ($(this).attr("method") != "get") { $(this).append('<input type="hidden" name="RPiZHMdbNYyt" value="wimoqvRFLUfO" />'); }
if ($(this).attr("method") != "get") { $(this).append('<input type="hidden" name="MLbOnVgTt" value="MBri[LQ4N" />'); }
                return true;
            });

			
            jQuery.ajaxSetup({
                beforeSend: function (e, data) {

                    //console.log(Object.getOwnPropertyNames(data).sort());
                    //console.log(data.type);

                    if (data.type !== 'POST') return;

                    if (typeof data.data === 'object' && data.data !== null) {
						data.data.append("ZHoGFhQlNxwMkPqI", "1S3jYpvWBGbXJETi");
data.data.append("dBAMxnO-gmNza", "V4m[xs8bIuS.r");
data.data.append("RPiZHMdbNYyt", "wimoqvRFLUfO");
data.data.append("MLbOnVgTt", "MBri[LQ4N");
                    }
                    else {
                        data.data =  data.data + '&ZHoGFhQlNxwMkPqI=1S3jYpvWBGbXJETi&dBAMxnO-gmNza=V4m[xs8bIuS.r&RPiZHMdbNYyt=wimoqvRFLUfO&MLbOnVgTt=MBri[LQ4N';
                    }
                }
            });

        });
	</script>
	</body>
</html>
